23.25 运行环境

sessionInfo()
## R version 4.1.0 (2021-05-18)
## Platform: x86_64-pc-linux-gnu (64-bit)
## Running under: Ubuntu 20.04.2 LTS
## 
## Matrix products: default
## BLAS:   /usr/lib/x86_64-linux-gnu/blas/libblas.so.3.9.0
## LAPACK: /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3.9.0
## 
## locale:
##  [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
##  [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
##  [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
##  [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
##  [9] LC_ADDRESS=C               LC_TELEPHONE=C            
## [11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       
## 
## attached base packages:
## [1] stats     graphics  grDevices utils     datasets  methods   base     
## 
## other attached packages:
## [1] patchwork_1.1.1 extrafont_0.17  gganimate_1.0.7 ggplot2_3.3.5  
## [5] magrittr_2.0.1 
## 
## loaded via a namespace (and not attached):
##  [1] progress_1.2.2    tidyselect_1.1.1  xfun_0.24         bslib_0.2.5.1    
##  [5] purrr_0.3.4       lattice_0.20-44   splines_4.1.0     colorspace_2.0-2 
##  [9] vctrs_0.3.8       generics_0.1.0    htmltools_0.5.1.1 viridisLite_0.4.0
## [13] mgcv_1.8-36       yaml_2.2.1        utf8_1.2.1        rlang_0.4.11     
## [17] jquerylib_0.1.4   pillar_1.6.1      glue_1.4.2        withr_2.4.2      
## [21] DBI_1.1.1         tweenr_1.0.2      lifecycle_1.0.0   stringr_1.4.0    
## [25] munsell_0.5.0     gtable_0.3.0      evaluate_0.14     labeling_0.4.2   
## [29] knitr_1.33        fansi_0.5.0       gifski_1.4.3-1    Rttf2pt1_1.3.8   
## [33] highr_0.9         Rcpp_1.0.7        scales_1.1.1      jsonlite_1.7.2   
## [37] farver_2.1.0      hms_1.1.0         digest_0.6.27     stringi_1.7.3    
## [41] bookdown_0.22     dplyr_1.0.7       grid_4.1.0        tools_4.1.0      
## [45] sass_0.4.0        tibble_3.1.2      crayon_1.4.1      extrafontdb_1.0  
## [49] pkgconfig_2.0.3   Matrix_1.3-4      ellipsis_0.3.2    prettyunits_1.1.1
## [53] assertthat_0.2.1  rmarkdown_2.9     R6_2.5.0          nlme_3.1-152     
## [57] compiler_4.1.0